Posts Tagged ‘static’

Force10 MXL: Initial Configuration

March 14, 2015

Continuing a series of posts on how to deal with Force10 MXL switches. This one is about VLANs, port channels, tagging and all the basic stuff. It’s not much different from other vendors like Cisco or HP. At the end of the day it’s the same networking standards.

If you want to match the terminology with Cisco for instance, then what you used to as EtherChannels is Port Channels on Force10. And trunk/access ports from Cisco are called tagged/untagged ports on Force10.

Configure Port Channels

If you are after dynamic LACP port channels (as opposed to static), then they are configured in two steps. First step is to create a port channel itself:

# conf t
# interface port-channel 1
# switchport
# no shutdown

And then you enable LACP on the interfaces you want to add to the port channel. I have a four switch stack and use 0/.., 1/.. type of syntax:

# conf t
# int range te0/51-52 , te1/51-52 , te2/51-52 , te3/51-52
# port-channel-protocol lacp
# port-channel 1 mode active

To check if the port channel has come up use this command. Port channel obviously won’t init if it’s not set up on the other side of the port channel as well.

# show int po1 brief

port_channel

Configure VLANs

Then you create your VLANs and add ports. Typically if you have vSphere hosts connected to the switch, you tag traffic on ESXi host level. So both your host ports and port channel will need to be added to VLANs as tagged. If you have any standalone non-virtualized servers – you’ll use untagged.

# conf t
# interface vlan 120
# description Management
# tagged Te0/1-4
# tagged Te2/1-4
# tagged Po1
# no shutdown
# copy run start

I have four hosts. Each host has a dual-port NIC which connects to two fabrics – switches 0 and 2 in the stack (1 port per fabric). I allow VLAN 120 traffic from these ports through the port channel to the upstream core switch.

You’ll most likely have more than one VLAN. At least one for Management and one for Production if it’s vSphere. But process for the rest is exactly the same.

The other switch

Just to give you a whole picture I’ll include the configuration of the switch on the other side of the trunk. I had a modular HP switch with 10Gb modules. A config for it would look like the following:

# conf t
# trunk I1-I8 trk1 lacp
# vlan 120 tagged trk1
# write mem

I1 to I8 here are ports, where I – is the module and 1 to 8 are ports within that module.

Advertisement

Routing Basics

August 6, 2012

Interfaces and Default routes

Routers use Layer 3 IP addressing when deciding where packets should go to. Hence each router interface should have an IP address, otherwise interface won’t be used at all. You simply go:

configure terminal
interface Fa0/0
ip address 10.1.1.1 255.255.255.0

Now router knows about 10.1.1.0/24 corporate network (it’s called “connected route”) and route packets destined to it through Fa0/0 interface. It could be a number of switches behind Fa0/0.

From the opposite site router is usually connected to the Internet (links between routers are usually /30 networks with 2 useable addresses):

configure terminal
interface Fa0/1
ip address 172.16.3.2 255.255.255.252

To tell the router that Fa0/1 is the outside interface where packets to all other networks go, you configure a default route (which is defined as route to network 0.0.0.0):

ip route 0.0.0.0 0.0.0.0 172.16.3.2

Static routes and RIP

Now the reasonable question here is what if we have several networks/routers behind the border router. How will they know about each other’s networks?

One answer is static routes. You can tell router1 that router2 has network2 behind it by adding a static route to the network2 on the router1:

ip route 10.1.2.0 255.255.255.0 10.1.128.254

Here routers are connected using network 10.1.128.252/30 and router2 has network 10.1.2.0/24 behind it. 10.1.128.254 is the router2 ip address (next hop) where router1 should send packets for network 10.1.2.0. If you have many networks in organization, then static routes are obviously not a solution. It’s nearly impossible to configure all routers with static routes to all networks. That is where routing protocols come into picture.

The most primitive routing protocol which is common in LANs is Routing Information Protocol or simply RIP. Using RIP all routers exchange information about routes they know. As a result of RIP convergence all routers know about all networks which exist in corporate LAN. RIP is not meant to be used in WANs due to excessive amount of traffic. Each router sends RIP updates in 30 seconds. Since receiving router in its turn forwards this update to all its interfaces, it would simply paralyze the Internet. To enable RIP updates do the following:

configure terminal
router rip
version 2
network 199.1.1.0
network 10.0.0.0

This tells router to send RIP updates about all its networks on interfaces where networks 199.1.1.0 and 10.0.0.0 are configured.

RIP updates propagate as a broadcast storm. So if router has redundant links, it can receive RIP information about the same network from several interfaces. RIP uses distance in that case. Each time packet comes to a router, link with the shortest path is used to forward it.