Posts Tagged ‘WAN’

NetApp SnapMirror Optimization

May 31, 2013

gzipSnapMirroring to disaster recovery site requires huge amount of data to be transferred over the WAN link. In some cases replication can significantly lag from the defined schedule. There are two ways to reduce the amount of traffic and speed up replication: deduplication and compression.

If you apply deduplication to the replicated volumes, you simply reduce the amount of data you need to be transferred. You can read how to enable deduplication in my previous post.

Compression is a less known feature of SnapMirror. What it does is compression of the data being transferred on the source and decompression on the destination. Data inside the volume is left intact.

To enable SnapMirror compression you first need to make sure, that all your connections in snapmirror.conf file have names, like:

connection_name=multi(src_system,dst_system)

Then use ‘compression=enable’ configuration option to enable it for particular SnapMirror:

connection_name:src_vol dst_system:dst_vol compression=enable 0 2 * *

To check the compression ration after the transfer has been finished run:

> snapmirror status -l

And look at ‘Compression Ratio’ line:

Source: fas1:src
Destination: fas2:dest
Status: Transferring
Progress: 24 KB
Compression Ratio: 3.5 : 1

The one drawback of compression is an increased CPU load. Monitor your CPU load and if it’s too high, use compression selectively.

Advertisement

Routing Basics

August 6, 2012

Interfaces and Default routes

Routers use Layer 3 IP addressing when deciding where packets should go to. Hence each router interface should have an IP address, otherwise interface won’t be used at all. You simply go:

configure terminal
interface Fa0/0
ip address 10.1.1.1 255.255.255.0

Now router knows about 10.1.1.0/24 corporate network (it’s called “connected route”) and route packets destined to it through Fa0/0 interface. It could be a number of switches behind Fa0/0.

From the opposite site router is usually connected to the Internet (links between routers are usually /30 networks with 2 useable addresses):

configure terminal
interface Fa0/1
ip address 172.16.3.2 255.255.255.252

To tell the router that Fa0/1 is the outside interface where packets to all other networks go, you configure a default route (which is defined as route to network 0.0.0.0):

ip route 0.0.0.0 0.0.0.0 172.16.3.2

Static routes and RIP

Now the reasonable question here is what if we have several networks/routers behind the border router. How will they know about each other’s networks?

One answer is static routes. You can tell router1 that router2 has network2 behind it by adding a static route to the network2 on the router1:

ip route 10.1.2.0 255.255.255.0 10.1.128.254

Here routers are connected using network 10.1.128.252/30 and router2 has network 10.1.2.0/24 behind it. 10.1.128.254 is the router2 ip address (next hop) where router1 should send packets for network 10.1.2.0. If you have many networks in organization, then static routes are obviously not a solution. It’s nearly impossible to configure all routers with static routes to all networks. That is where routing protocols come into picture.

The most primitive routing protocol which is common in LANs is Routing Information Protocol or simply RIP. Using RIP all routers exchange information about routes they know. As a result of RIP convergence all routers know about all networks which exist in corporate LAN. RIP is not meant to be used in WANs due to excessive amount of traffic. Each router sends RIP updates in 30 seconds. Since receiving router in its turn forwards this update to all its interfaces, it would simply paralyze the Internet. To enable RIP updates do the following:

configure terminal
router rip
version 2
network 199.1.1.0
network 10.0.0.0

This tells router to send RIP updates about all its networks on interfaces where networks 199.1.1.0 and 10.0.0.0 are configured.

RIP updates propagate as a broadcast storm. So if router has redundant links, it can receive RIP information about the same network from several interfaces. RIP uses distance in that case. Each time packet comes to a router, link with the shortest path is used to forward it.